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CAD - Objet Studio Workflow 

Understanding the interface between your CAD software and the Connex 3-D printer lets you 
get the most out of innovative Connex technology.

Overview
The basic workflow for printing parts from more than one model material (Mixed Part™ ) consists of five 
phases, as illustrated in the following figure.

The workflow begins with the design of an assembly of parts whose solid bodies are distinct objects.

This ensures that the model will be separable into its components (shells) when saved in STL format.

Models containing “holes” or “gaps” adversely affect quality when printed. Therefore, it is recommended that 
you perform a geometry check of the STL files before continuing. If there is a problem with a file, the software 
attempts to fix the geometry.

Objet Studio™ contains a full range of tools for printing Mixed Parts. You can print several individual models 
at once, using different model materials, and you can print the distinct components of one model, each with 
a different material. To make this possible, each component must be a separate STL file. This is achieved by 
either loading the model into Objet Studio as an assembly, or by separating the model into shells with Objet 
Studio software.

The following pages describe, in detail, how your CAD software fits into the workflow for printing models with 
Connex 3-D Printers.
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Figure 1: Phases of the CAD-Objet Studio workflow 
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Smart Shell Design

It is recommended to save separate STLs (shells) for each color and then insert 
them as an assembly. The number of STLs can be the number of colors used, 
even if many parts use the same color. Color assignment is done in Objet 
Studio.

Opacity

Consider the surface thickness of parts or shells when preparing them for 
printing in different colors. This is especially important when printing a light 
color next to a dark one (for instance, yellow next to black).

To maintain an opaque color, the surface thickness of adjacent shells should be 
at least 2 mm.

Overlapping Shells

Avoid designing parts with overlapping shells. The color of overlapping 
parts cannot be properly controlled and the results are unpredictable. This is 
especially true when one of the parts is a light color and the other is a dark 
color.

It is recommended to use Boolean tools in your CAD software to eliminate 
overlapping areas.

Translucency

For translucent parts, in Objet Studio select a combination of clear material 
(VeroClear) and a color. Thinner parts are more translucent than thicker parts.

Designing Color Models 
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Figure 2: Creating a multi-bodied model in SolidWorks

During the model-design phase, you decide how to create the model, either as 
an assembly of parts, or as a multi-bodied model. Connex 3-D printers support 
both methods.

Model Assembly
With a model assembly, each part of the model is saved as a separate STL file. 
Taken together, the model appears as one unit. However, because each part 
is an independent element, special treatment can be applied to them in Objet 
Studio.

Multi-Bodied Model
With a multi-bodied model, each part of the model is designed as an 
individual, distinct component. Seen as a whole, the model is one unit. 
However, because of the multi-bodied design, the distinct parts can be isolated, 
in Objet Studio, for special treatment.

Creating Multi-Bodied Models
To create multi-bodied models, use the following commands:

      ; Extrude Boss; Cut (applies also to thin features)

      ; Revolve Boss; Cut (applies also to thin features) 

      ; Sweep Boss; Cut (applies also to thin features) 

 Surface Cut

      ; Boss; Cut thicken

 Cavity

Make sure that the Merge result check box is not selected.

Phase 1: 
Designing 
Models in 
SolidWorks

Designers using SolidWorks 2003 (and later)
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SolidWorks supports the saving of model designs in STL format, at all levels of 
design, for both individual parts and assemblies, including the ability to save a 
multi-bodied model as a single STL.

To save a multi-bodied model or a model assembly in STL Format:

1. From the File menu, click Save as. 

The Save As dialog box opens.

Phase 2: 
Saving a 
Model Design 
in STL Format

Figure 3: Save As dialog box in SolidWorks

2. From the Save as type drop-down menu, select STL (*.stl). 

3. Click Options... 

The Export Options dialog box appears, and the model is displayed in 
tessellated view. STL is selected as the File Format (see Figure 4). 
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4. In the Export Options dialog box (see Figure 5), in the Output as section, 
select Binary. (The resulting file size will be smaller than if saved as 
“ASCII.”)

5. In the Resolution section, select the appropriate option. 

If you select Custom, you can manually adjust the Deviation and Angle 
settings, as needed.

These settings affect the tessellation of non-planar surfaces, as follows:

•	 Lower Deviation settings result in finer tessellation.

•	 Lower Angle settings result in with greater accuracy, noticeable in small 
details. 

As a rule, the higher the resolution, the larger the size of the file, and the 
longer it takes to generate.

Figure 4: Export Options dialog box and SolidWorks screen
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6. Make sure that these check boxes are not selected:

•	 Do not translate STL output data to positive space  
This ensures that the parts maintain their original position in global space, 
relative to the origin. 

•	 Save all components of an assembly in a single file
This ensures that each component is saved as a separate STL file. 
Note: This check box is not relevant when saving multi-bodied models, since 
the model is saved as single STL file.

7. Click OK. 

8. In the Save As dialog box, click Save. 

9. In the confirmation message, click Yes (see figures 6 and 7).

Figure 5: Export Options dialog box
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Figure 6: Save confirmation message—for saving a model assembly

Figure 7: Save confirmation message—for saving a multi-bodied model
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There are two procedures for opening model files in Objet Studio, one for opening 
an assembly of STL files, the other for opening a single, multi-bodied STL file.

A. Placing a model assembly on the Objet Studio build tray
1. Open the Insert dialog box: 

•	 Right-click in the build tray and select Insert.

•	 From the Object menu, select Insert.

•	 Click the Insert Model icon 

Phase 3: 
Opening  
Model Files  
in Objet Studio 
Software

Figure 8: Selecting an assembly in the Insert dialog box

2. Select all of the assembly’s component STL files.

3. Select the Assembly check box and click Open. 
The selected components are inserted as a complete, integrated model, and 
they are listed in the hierarchy pane, on the left (see Figure 9).
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B. Placing a multi-bodied model on the build tray and separating it into shells
1. Open the Insert dialog box: 

•	 Right-click in the build tray and select Insert.

•	 From the Object menu, select Insert.

•	 Click the Insert Model icon 
 
.

2. Select the STL file, and click Open.

Figure 9: Assembly inserted in Objet Studio

Figure 10: Selecting a single STL file in the Insert dialog box

The model is placed on the build tray and a single element appears in the 
hierarchy pane, on the left (see Figure 11).
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Figure 11: Single object inserted in Objet Studio

3. Select the object, and separate it into shells:

•	 From the Object menu, click Separate into Shells. 

•	 In the Model Settings tab,  Multiple Materials section, click Separate to Shells.

A dialog box opens in which you can specify where to save the component STL 
files (shells).

Figure 12: Folder selection

Figure 13: Object after being converted to an assembly

4. Click OK. 

Objet Studio splits the object into an assembly of component parts (shells), 
each a separate STL file. The object now appears on the build tray, and in 
the hierarchy pane, as an assembly of shells (see Figure 13).
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When different model materials appear in the Tray Settings ribbon, you can 
print objects (shells) with either material or with a combination of them – Digital 
Materials.

1. Select an object on the build tray.

2. Select the desired model material from: the pop-up toolbar.

On color printers, you can assign materials to models using a color palette if 
certain combinations of materials are available. 

Other color combinations can be used 
with duotone palettes (two-color digital 
materials).

If more colors are needed, consider 
printing separate parts to assemble as a 
post-printing process.
Notes:
•	 Colors selected in Objet Studio might not accurately reflect the printed color due to 

shading in 3D views and different screen calibrations.

•	 In Objet Studio, transparent colors appear opaque.

Printing Transparent Parts
Transparency

UV light causes a yellow tint on transparent parts. For better results, limit 
exposure of transparent parts to UV light. For this reason, the surface finish 
you choose affects the clarity of parts printed with VeroClear.

Matte Surface Finish – It is preferable to print transparent parts with a matte 
surface finish. The extra support used to cover matte surfaces provides 
protection from UV light and therefore improves clarity.

Glossy Surface Finish – Arrange parts with a glossy surface finish so that they 
have similar heights. This reduces the number of passes the UV light needs to 
make over the models during printing.

There are various post-processing techniques you can use to improve a part’s 
transparency. For example, polishing parts printed with VeroClear improves 
clarity. Applying a coat of clear lacquer gives parts a shine and protects their 
surfaces. For details and more suggestions, refer to the “Guide to Post Printing 
Applications”

•	 the Multiple Materials section on the Materials Settings ribbon

Phase 4: 
Assigning 
Model 
Materials to 
Shells
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Figure 16: Finished model

When the models on the build tray are ready to be printed, place them in the 
print queue:

•	 From the Tray Settings ribbon, in the Build Process section, click 
Notes:
•	 Color printing is always performed in DM mode.

•	 Gloss and matte surfaces might have slightly different hues.

•	 Pausing a print job for more than 30 minutes might cause a color variation 
in the Z direction. To avoid unnecessary pauses, before printing sure that the 
material cartridges are sufficiently full and that the waste container is empty.

The Connex 3D printer builds the model, using the materials assigned to the 
model’s components.

Phase 5: 
Printing 
the Model
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Designers using Pro/ENGINEER (Wildfire 2 and later)

Phase 1: 
Designing a 
Model in  
Pro/ENGINEER

Since Pro/ENGINEER does not enable designing multiple-bodied models (as 
is possible with SolidWorks), non-continuous models must be handled as Pro/E 
assemblies, not as parts. This does not present a problem when beginning the 
design in Pro/E, as will be explained below.

However, when importing files, especially those saved in a neutral format (STEP 
or IGES, for example), multiple-bodied models must be imported as assemblies 
to take advantage of the multiple model-material features in Connex 3-D printer. 
For this reason, it is recommended to import all neutral files as assemblies.

Phase 2: 
Saving a 
Model Design 
in STL Format

Pro/E allows you to save both parts and assemblies in the STL file format. 
Handling the model design as an assembly enables you to print the model’s 
components with different model materials on Connex 3-D printers. Models 
designed and exported as parts can only be printed with a single model 
material. However, using the Mixed Tray™ feature, you can print several parts, 
each with a different model material, at the same time.

This section describes saving both parts and assemblies in STL format, for 
printing with Connex 3-D printers.

Saving a Pro/E Part in STL Format
1. Check that the model design is continuous and watertight.  

This step is especially important if the design was imported from a neutral 
design format. Non-continuous bodies are likely to result in defective 
models. You cannot always check for continuity by examining the model 
displayed in shaded view. Therefore, use the following method:

a View the model with hidden lines displayed.
b From the View menu, select Display Setting > Scheme > PreWildfire. 

The model surfaces are displayed in magenta. If the design is continuous, 
the contour lines are white. If there are gaps, the lines are yellow.

c Fix the model design, if necessary, before saving it as an STL file.

2. From the File menu, select Save a Copy. 
The Save a Copy dialog box appears.

3. From the Type pull-down menu, select STL (see Figure 17).
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The Export STL dialog box appears.

Figure 17: Saving a part as an STL file

Deviation Control
The Deviation Control settings in the Export STL dialog box affect the resolution 
of the model and the size of its file. 

•	 Chord Height – specifies the maximum distance between a chord and the 
part’s surface (see Figure 19). This controls the degree of tessellation of 
the model surface. The smaller the chord height, the less deviation from the 
actual part surface, but the bigger the file.

Figure 18: Export STL dialog box
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Figure 19: Chord Height

•	 Angle Control – regulates how much additional tessellation occurs along 
surfaces with small radii. The smaller the radii, the more triangles are used. 
The setting can be between 0 and 1. Unless a higher setting is necessary, to 
achieve smoother surfaces, 0 is recommended.

4. When you have made all of the required settings, click Apply and OK to 
create the STL file.

Saving a Pro/E Assembly in STL Format
1. From the File menu, select Save a Copy. 

The Save a Copy dialog box appears.

2. From the Type pull-down menu, select STL. The Export STL dialog box 
appears. In addition to the settings used when exporting a part STL, this 
dialog box enables you to specify the parts of an assembly to either include 
or exclude from the resulting STL file. In the dialog box shown in Figure 20, 
one of the parts of the assembly (the tire) has been excluded, leaving  
two parts (the hub and the main wheel) to be exported to the STL file. The 
model resulting from these settings (when you click OK) is shown on the left.

3. When you have made all of the required settings, click Apply and OK to 
create the STL file.

Figure 20: Export STL settings for assemblies and the resulting model saved

For phases 3–5, see pages 7–10.
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Designers using Catia (V5 and later)

Phase 1: 
Designing 
and Handling 
Models in 
Catia

With a special add-on module, you can save designs in Catia as STL files. 
Catia V5 is capable of exporting STL files from parts (CatiaPART files), but not 
from assemblies (CatiaPRODUCT files) or geometrical representations (car 
files). Therefore, source files, including those saved in a neutral format (STEP 
or IGES, for example), must be exported as parts. If the source design was 
saved as an assembly, it is imported as a product. To export it as an STL file, 
you must convert it to a multi-bodied part. The procedure described below is 
one of several methods for doing this. Since Catia 5 supports non-continuous 
model designs, importing geometry into a part by copying and pasting is not 
problematic.

Importing a model design in Catia for export as an STL file
Catia can import almost any design-file format, but only those that include solid 
data (IGES, STEP, Parasolid, etc.) can be exported from Catia as STL files.

1. From the File menu, select Open, and open the source file. 
If the source design was saved as an assembly, it is imported as a 
CatiaPRODUCT model (see Figure 21).

2. Save the product file.

3. From the File menu, select New > Part, and give it the name of one of the 
components.

4. In the product window, select this component (Figure 21), and copy it (with 
the Edit menu  
or the right-click pop-up menu).

5. In the part window, paste the component.

6. Repeat steps  4 and  5 until you have copied all of the components and 
pasted them as individual parts.

Figure 21: An assembly imported into Catia
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Figure 22 shows the result of pasting the components of the model from Figure 
21 as individual parts.

Figure 22: Assembly components saved as individual parts

7. From the File menu, select New > Part, and give it a name suitable for the 
combined model.

8. Copy each of the individual components (parts) from the working files 
(Figure 22) and paste them into the new (combined) model file (Figure 23).

Figure 23: Multi-bodied part assembled from individual parts
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Since the geometries of all of the parts are retained, they should be aligned 
correctly in the combined part. The new, multi-bodied part is now ready to be 
exported as an STL file.

Re-aligning parts (if necessary)
Occasionally, because of the way the original assembly was designed, some 
of the components may not align correctly in the combined part. If so, you must 
align them, using the Constraints feature, from the Insert menu (see Figure 24).

Figure 24: Re-aligning parts

Phase 2: 
Saving a 
Model Design 
in STL Format

Before saving the file, it is advisable to review the settings that determine the 
accuracy of the model and the size of the file. To see these parameters: 

1. From the Tools menu, select Options.

2. In the Options dialog box, display the Performance tab.

3. Under the General category (on the left), select Display.

4. Pay attention to the 3D Accuracy settings (see Figure 25).

•	 Fixed – The lower the setting, the finer the details of the model in the STL file. 
A very small setting results in a very large STL file.

•	 Curves’ accuracy ratio – The higher the setting, the smoother the surface will 
be, when dealing with complex geometries, especially if surfaces contain 
sudden small changes with small radii (like the bumps on a golf ball).
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Figure 26: Saving the Catia files as an STL file

3. Click Save. 

Please note: 
•	 Hidden contour lines are not exported in the STL file.
•	 The Catia part does not need to be continuous.

For phases 3–5, see pages 8–12.

When the Catia part is ready to be saved as an STL file, proceed as follows:

1. From the File menu, select Save As.

2. In the Save As dialog box, select STL from the Save as type pull-down list. 

Figure 25: Setting the 3D Accuracy settings in the Options dialog box
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